Jump to content
artwood

Engine Getting Up To 210o, Fan Not Turning On

Recommended Posts

artwood

Hey guys,

 

I got my 07 a few weeks ago and haven't really been able to do much riding. Since it's been below freezing, I've been starting it and letting it warm up once a week in my garage. I notice the fan won't come on and I let the temp climb to 210o before shutting it off. What temp should the fan be coming on? Is this something the dealer should look at? Thanks in advance.

Share this post


Link to post
Share on other sites
shinyribs

Fan doesn't come on til 220, boss. Nothing to worry about. 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
norcal616

Its best to pull the battery and bring it inside and winterizing the bike rather than letting it idle

  • Like 1

Share this post


Link to post
Share on other sites
Duke

Yeah, the factory setting is that the fan kicks in at 220 degrees.

 

You can always get your ECU flashed by 2WDW and one of the quality of life changes is the fan kicks in at 195 degrees.

Share this post


Link to post
Share on other sites
Beemer

I assume you're charging the battery.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.