Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
zadori

Cyclops Headlight stopped working

Recommended Posts

zadori

Hey guys,

 

In June I swapped my headlight to a Cyclops 7000 model. And tonight while riding back home I noticed that it didn't light up anymore. I checked real quick and all the wires seem okay, I will have to do some more looking into it around the weekend, but has this happened to anyone here and if so what could be the cause of this? The high and low beams both do not work :(

Edited by zadori

Share this post


Link to post
Share on other sites
zadori

I was too curious so I opened it up, and I have power at my regular socket but going into the small circuit there is no output. The wires seem "loose" in there, so I'll try calling cyclops tomorrow if I can get only that little circuit and wire

  • Like 1

Share this post


Link to post
Share on other sites
Cruizin

@zadori They have awesome cust svc. (800) 624-0278 or Info@CyclopsAdventureSports.com

 

Business Hours:

Monday: 9am - 4:30pm PST

Tuesday: 9am - 4:30pm PST

Wednesday: 9am - 4:30pm PST

Thursday: 9am - 4:30pm PST

Friday: 9am - 3pm PST

 

Contact them, and check back and let us know what happened. Tell em Rob at the fz07 forum sent ya! 

  • Like 1

Share this post


Link to post
Share on other sites
zadori
23 hours ago, Cruizin said:

@zadori They have awesome cust svc. (800) 624-0278 or Info@CyclopsAdventureSports.com

 

Business Hours:

Monday: 9am - 4:30pm PST

Tuesday: 9am - 4:30pm PST

Wednesday: 9am - 4:30pm PST

Thursday: 9am - 4:30pm PST

Friday: 9am - 3pm PST

 

Contact them, and check back and let us know what happened. Tell em Rob at the fz07 forum sent ya! 

I talked with them today, excellent customer service indeed! They are sending out a driver under warranty so I can test out if it is indeed that the issue! 

  • Like 1

Share this post


Link to post
Share on other sites
sunblock

What happened?

Share this post


Link to post
Share on other sites
Beemer

zadori, what did you find out?

Share this post


Link to post
Share on other sites
zadori

Sorry for the delay in the answer. I have been pretty occupied!

With the replacement driver everything worked out perfectly, so being curious nature, I unboxed the old one to find out that two wires had unwelded themselves from the PCB. I've put the new driver with less of a stress on the wires.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.