Jump to content
Sign in to follow this  
pj311

Front Signal LED Wiring

Recommended Posts

pj311
Hi Guys,
 
I have a 2016 FZ 07 with DRL's here in Canada. Ive upgraded my rear signals to LED with no issue and am looking at doing the fronts now, here is my problem;
Stock wire is blue, brown, and beige.
I have purchased Yamaha turn signal harness from here it has a red yellow and black wire, this plugs directly into the bikes wiring harness.
I then have the Blinker Genie from here which has a red white and black on one end and a yellow on the other.
Finally is the LED which is a 2 wire yellow and black.
 
So does anybody have this same setup or know the bikes wiring well enough to tell me how to connect the signal harness, to the blinker genie, to the led?
 
Thanks
 

Share this post


Link to post
Share on other sites
ducttapewd40
I don't know how the signal harnesses are going to be oriented when you plug them in, so just make sure to look at the wire on the opposite end of the harness on the bike's wiring that you are plugging it into.
 
One the stock wiring: black is ground, tan is daytime running. On the right side, green is your blinker. On the left, brown is blinker.
 
Ground will go to the genie and either side of the lamp.
 
Tan will go to red on the genie.
 
On the right side, green will go to white on the genie. On the left, brown will go to white on the genie.
  • Like 1

Share this post


Link to post
Share on other sites
ducttapewd40
Oops. Also the yellow on the genie to the other side of the lamp.
 
The page you have a link to for the genie has an "installation" tab which shows a good diagram for the wiring.
 
 
 
 

Share this post


Link to post
Share on other sites
pj311
Thanks much, so I need to splice into the black (ground) before the genie and run a separate black wire from that to the bulb correct?

Share this post


Link to post
Share on other sites
ducttapewd40
Thanks much, so I need to splice into the black (ground) before the genie and run a separate black wire from that to the bulb correct?
Yes.  I'd probably just twist the two leads from the genie and the lamp together, then connect them to the ground from the bike. 
I was wrong earlier when I said to connect to either side of the lamp.  Polarity matters on leds.  Make sure yellow on the genie goes to yellow on the lamp and splice the blacks all together.

Share this post


Link to post
Share on other sites
mjh937
Make sure the LED turn signals you get are okay to be on continuously. One guy posted a photo of his melted turn signal a while back.
  • Like 1

Share this post


Link to post
Share on other sites
SkH
Perhaps I'm too late with the reply, but my old LEDs had the same wiring setup:
 
LED with yellow and black.
Blinker Genies: Yellow and red/white/black
OEM harness from MD: Red/White/Black
 
The black wires (ground) from all 3 components were all soldered together.
 
This is how it looks, you should be able to make it out:
 
IMG_0026.jpg
 
Anyway, I ran those for about 3k miles before I removed them (reverted back to stock).  If you are wondering why I reverted back, because my wife also now rides the FZ07 (I have 3 bikes total) and I anticipated her dropping the FZ07 (she hasn't yet) so I put back stock blinkers.
 

.

Share this post


Link to post
Share on other sites
pj311
Thanks so much for your help guys, appreciate the responses.
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


×

Important Information

By using this site, you agree to our Terms of Use.