Jump to content
Sign in to follow this  
oggie03

Turn Signal Help Please !!! LED

Recommended Posts

oggie03
Hi All, 
I am new to this site so sorry if I posted in the wrong place but I am looking for some help. I have a 2016 fz07. Recently purchased R&G aero turn signals. I also purchased the resistors. I installed all 4 and the blinkers are still blinking fast. The drl wire is not hooked up to anything. Does it need to be? I actually do not want the drl function but would like the blinkers to blink at normal speed. Any help would be great. 
 
Thank you in advance. 

Share this post


Link to post
Share on other sites
mjh937
It sounds like you probably did not hook up the resistors correctly. Do you have them connected in series? I used an electronic relay so that I did not have to bother with resistors.

Share this post


Link to post
Share on other sites
CapnKirk
Could be the wrong value resistors. If they do not pull the load of the OEM, your OEM relay will still flash fast.
 
Highly recommend changing to an electronic relay. It will solve your problem. I have already changed the rears to LED and am using an electronic relay with no issues.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


×

Important Information

By using this site, you agree to our Terms of Use.