Jump to content
Sign in to follow this  
pasiodg

Check engine light with no code

Recommended Posts

pasiodg
Just finished installing EJK and Ixil sx1 full exhaust with the recommended setting from their website. I took it for a test ride and CEL keeps coming on and it stays on once I past 5mph. Once I slow down (5mph and under) CEL goes off. Here's the setting I have in my EJK, G-5.5, Y-6, R-5.5 G/B-3.5, Y/B-3, R/B-1. Any ideas?

Share this post


Link to post
Share on other sites
12ival
did you disconnect the oxygen sensor?

Share this post


Link to post
Share on other sites
Simbadc650
It happened to me it was the sensor after I unplugged it was fine

Share this post


Link to post
Share on other sites
pasiodg
I tested both ways connected and disconnected o2 sensor and it was still giving me the CEL. Is there a waiting period when you disconnect or connect the o2 sensor before you run the bike again?

Share this post


Link to post
Share on other sites
username
When I put my EJK back in I forget to plug the fuel tank sensor back in and I got the same thing happen. I plugged it in easy peazy and it went away. Did you perhaps not plug it back in fully?

Share this post


Link to post
Share on other sites
pasiodg
Is that the sensor on the right close to the bolt that's holds the tank in place? I just checked it and it's plug. Do you guys think there something wrong with the he EJK?

Share this post


Link to post
Share on other sites
username
Is that the sensor on the right close to the bolt that's holds the tank in place? I just checked it and it's plug. Do you guys think there something wrong with the he EJK?
 
 
That could be the case also. If everything is plugged in properly then there isn't much else that could be wrong. What happens if you unplug the EJK and put everything back to stock? Alot of work but if it goes away then you narrowed down your problem a bit more.

Share this post


Link to post
Share on other sites
pasiodg
Thanks! Once I get a chance I'll try to unplug EJK and try with out it. I'll keep you guys updated.

Share this post


Link to post
Share on other sites
pasiodg
EJK unplug and just took it for a test ride and no CEL.

Share this post


Link to post
Share on other sites
username
EJK unplug and just took it for a test ride and no CEL.
 
 
Well I would contact the seller that you got the EJK from for a refund. Sounds like it has to be the EJK if everything was installed right. That's a pain to take your bike apart and put it back together again and now have to go through the whole process one more time. I would definitely ask for some free stuff for the troubles from the seller ;)

Share this post


Link to post
Share on other sites
Simbadc650
Call ejk see what they say

Share this post


Link to post
Share on other sites
pasiodg
I just called them and they gonna send me a placement. Thanks for the help guys.

Share this post


Link to post
Share on other sites
soulshifter
Thanks for this post, I am having the exact same problem, guess I will be taking the bike apart again now. [HASH]Bikelife :)

Share this post


Link to post
Share on other sites
peteinpa
Starter button stuck on?

Got new red 2015 FZ-07 on 7/22/16!
Black 2006 Honda ST1300 53K miles.

Share this post


Link to post
Share on other sites
soulshifter
I checked for that, but seems the starter button is 100% okay. Since this post I stripped the bike down, took the EJK off and ran it as normal, engine light still on with no error code. Checked all the connectors, all plugged in and steady. I'm not quite sure what on earth is causing this now...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


×

Important Information

By using this site, you agree to our Terms of Use.