Jump to content
Sign in to follow this  
wojo72

FZ07 running like crap.

Recommended Posts

wojo72
I took the FZ07 out for a quick run today. The bike starts and idles fine but is way down on power. The bike won't pull past 6k in any gear. The gas is only a couple of weeks old. Not sure to start on troubleshooting. I'm looking for suggestions.
 
Thanks!
 

Share this post


Link to post
Share on other sites
fzonly1
I read a thread once where a guy was having a similar issue. Turned out a mouse made a nest in his air filter. I'd start there and make sure there isn't anything restricting air flow. How long did you ride that tank of gas before you noticed a change?
  • Like 1

Share this post


Link to post
Share on other sites
wojo72
I burned up MAYBE 1/4 of a tank before I parked it.  It was acting stupid as soon as I fired it up today.

Share this post


Link to post
Share on other sites
ornery
Is it too early for a spark plug to start failing? Should the computer be throwing a code if it's missing?

“The real cycle you're working on is a cycle called yourself.”
— Robert M. Pirsig (Zen and the Art of Motorcycle Maintenance: An Inquiry Into Values)

Share this post


Link to post
Share on other sites
wojo72
That's what I thought. No light on the cluster. It seems to rev past 6k in neutral.
 

Share this post


Link to post
Share on other sites
ornery
Well, where lawn equipment is concerned, some plugs test fine on the bench, but fail under load. You said it started going away at higher RPM. That's what "sparked" my post. They're not particularly easy to get at, but I doubt they cost an awful lot. I hate to just throw parts at a problem, but if they're cheap enough, and there are no other ideas, might as well.

“The real cycle you're working on is a cycle called yourself.”
— Robert M. Pirsig (Zen and the Art of Motorcycle Maintenance: An Inquiry Into Values)

Share this post


Link to post
Share on other sites
fooschnickens
I would echo checking the airbox. I've heard reports of lots of folks finding critters' nests packed in there, especially during the colder months or when the bike has been sitting a while.
 
Apart from that, double check the connectors for your injectors and maybe try topping off the tank with some fresh gas if there's room.

Share this post


Link to post
Share on other sites
fzonly1
Siphon that gas outta there too. Get some fresh gas. (Not from same place u filled up).
  • Like 1

Share this post


Link to post
Share on other sites
Mr.Puss
If it is a critter nest you could cover the snorkel or hole with a piece of fine wire mesh. When I took off my snorkel and replaced my filter I chopped off and used that mesh and secured it under the plate. Works great!

Crush your enemies. See them driven before you. Hear the lamentations of their women.

Share this post


Link to post
Share on other sites
cndnmax
Do you have a fuel tuner or is everything stock? Does it feel like it's running on one cylinder?

Share this post


Link to post
Share on other sites
Guru
My bet is on lack of air. It's the season where critters make nests and store food. First thing I did was make a mash screen for the FZ07 but I forgot to do the ATV. Sure enough it ran like crap and they make a nest.
 
IMG_1046.jpg
 
  • Like 3

Share this post


Link to post
Share on other sites
fzonly1
 

If it is a critter nest you could cover the snorkel or hole with a piece of fine wire mesh. When I took off my snorkel and replaced my filter I chopped off and used that mesh and secured it under the plate. Works great!
Really good idea. I might do this.

Share this post


Link to post
Share on other sites
Beemer
When I've had similar problems in the past with cars I checked for loose spark plug wires, batt. elec. connections (the simplest things first) and that often proved to be the culprit. It's so new I wouldn't think it's anything major. I doubt any water was in your gas to begin with and doubt any condensation built up since you first put it away but it wouldn't hurt to siphon off/add fresh gas. Then again, it could be a critter thing as mentioned or something else. Good luck with it and let us know what was causing the problem after you've found it. Have a better new year!

Share this post


Link to post
Share on other sites
wojo72
Long story short it was the work of mice. The filter was jam packed with bird seed. My wife keeps a bag of it in the garage. I'll have to put that in some kind off container with a secure lid. I am having trouble finding a replacement air filter locally. Hopefully I remember where everything goes :)
  • Like 3

Share this post


Link to post
Share on other sites
Mr.Puss
Bird seed! I knew it! ;)
 
Im not laughing at your misfortune, but "jam packed with bird seed" is a good one.
 

Crush your enemies. See them driven before you. Hear the lamentations of their women.

Share this post


Link to post
Share on other sites
forcefed86
Well if it was jammed packed with the shet from colombia that would be one dope fz07!! Lol!!!
  • Like 1

Share this post


Link to post
Share on other sites
sorkyah
Long story short it was the work of mice. The filter was jam packed with bird seed. My wife keeps a bag of it in the garage. I'll have to put that in some kind off container with a secure lid. I am having trouble finding a replacement air filter locally. Hopefully I remember where everything goes :)
maybe an upgrade to k&n with a flash is in order?

ATGATT... ATTATT, two acronyms I live by.
 

Share this post


Link to post
Share on other sites
Beemer
Hmmmm, this is intriguing ... wife hates bike .... puts birdseed in same vicinity as bike ... mice love birdseed so mice get blamed ... you married one of the smart ones!   ;)  
  • Like 3

Share this post


Link to post
Share on other sites
rick
Well, if that was my "made in Italy" toy, I'd be pulling every electrical connector involved in making it run ( seemingly hundreds of 'em, everything except the lights, lol) and give a spray with this stuff http://www.amazon.com/Hosa-Cable-Deoxit-Contact-Cleaner/dp/B00006LVEU/ref=pd_sim_236_3?ie=UTF8&dpID=41esA2w9C%2BL&dpSrc=sims&preST=_AC_UL160_SR160%2C160_&refRID=1X2TSS4A6V99603VQPK1
 
If there was a magic elixir, this would be it. It'll take a connector green with oxidation and make it work like new again. You'll never smear dielectric grease on any electrical connector ever again.
  • Like 1

Share this post


Link to post
Share on other sites
Guru
It's a pretty regular occurrence where I live. Especially during the winter months. Here's the air filter of a friend's ATV. Ran like crap too..
 
IMG_1645.jpg
 
  • Like 2

Share this post


Link to post
Share on other sites
rick
Popcorn out the exhaust would make one heck of a vid!

Share this post


Link to post
Share on other sites
so1102
Popcorn out the exhaust would make one heck of a vid!
Ask and ye shall receive 
[video src=https://youtu.be/NSySqtRwS1M]
  • Like 3

Share this post


Link to post
Share on other sites
gregjet
We have a similar problem with mud wasps building mud nests in the inlets and exhausts ( and any other hole they can find). One day your bike runs fine the next you come to start it and it won't start. After stuffing around for hours you work out there is no exhaust ( or very little) expulsion. Oh look. deep down inside a lumpy ball of mud...
My poor whipper snipper suffers from mudwasp intake syndrome incessantly.
 

Go forth and modify my son...go forth and modify...

Share this post


Link to post
Share on other sites
sorkyah
Popcorn out the exhaust would make one heck of a vid!
Ask and ye shall receive 
[video src=https://youtu.be/NSySqtRwS1M]
But mommy... the popcorn is all oily and smells like a gas station

ATGATT... ATTATT, two acronyms I live by.
 

Share this post


Link to post
Share on other sites
rick
That's just hilarious.
 
Wonder if that requires a reflash?
 
And just imagine the conversation over warranty at the BMW dealer, lol.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


×

Important Information

By using this site, you agree to our Terms of Use.