Jump to content
Sign in to follow this  
hypnotik

SpeedoHealer on FZ-07?

Recommended Posts

hypnotik
I just got a SpeedoHealer to correct for my sprocket change and it doesn't work.  Has anyone installed one on their FZ-07 yet with luck?  I had one on my previous bike with no issues.
 
I sent them this email, we'll see what they say.
 
Hello,
I purchased SpeedoHealer model SH-V4 and harness SH-Y01 for my 2015 Yamaha FZ-07 as recommended by your website as the appropriate items for my bike. It does not work. I have installed several SpeedoHealers in the past with no problems, mainly the reason I buy and recommend your products. With the SpeedoHealer plugged in my speedometer does not work. When in the test mode and rotating the rear wheel, the “t” does not blink. I have tried inputing a correction factor as well as erasing the memory and using in transparent mode with no luck. When I unplug the unit and plug the speedometer back in with the factory connectors it works fine. How can we resolve this issue?
 
Thank you

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


×

Important Information

By using this site, you agree to our Terms of Use.