Jump to content
Sign in to follow this  
Skibum4106

FZ-07 Meter Speedometer ect

Recommended Posts

Skibum4106

Since  Hitting a Deer at  50  MPH last  Fall , now my FZ-07  Instrument panel won't  boot up anymore.. For a  while it  worked fine..   Then it got to the point that  I had to turn the key on and off a  few times.. Now  it's  just whacked and won't  boot up.
  I thought I  could find a  used one for a  2016  FZ-07  many wrecks and many  stripped for  racing ect..    but none used.
  Mine  is  2016  FZ-07  does not have  ABS
2RC-83500-00-00
    Any Ideas  or do I have to buy a new one?

Share this post


Link to post
Share on other sites
mjh937

I would check the connector and make sure all the wiring is secure.  It seems more likely that was damaged than the actual instrument cluster in an animal collision.  

Share this post


Link to post
Share on other sites
Skibum4106

My  thinking was that it was jarred so hard  it  broke the  tiny microcircuits..  I have  had  Issues  in GM cars and trucks  such was when the gas gauge was not  working hat to change the whole microcircuit board//
   Seems  I had  removed and had  unplugged the  board  before .. maybe it when I installed a windscreen ..

Share this post


Link to post
Share on other sites
mossrider

I've broken them in crashes twice and just buy new factory ones, they're only about $260. 

  • Like 2

Share this post


Link to post
Share on other sites
Skibum4106

Shop online for OEM Meter parts that fit your 2016 Yamaha FZ07 (FZ07GB), search all our OEM Parts or call at 269-385-1540

If  you  call this  place  they put you on hold for 20 minutes then hang  up on you..  You are supposed to order it all online..  I live  8 miles away so  I don't have to pay their high shipping rates..  I called them e-mailed and  texted  them friday with the ceral number for the bike..
  Must  be you crashed on a track ?

Share this post


Link to post
Share on other sites
mossrider

I use Partsfish.com out of Omaha but I see prices are way up, $497 now. I'm done crashing.

And you can order or pick up and they answer the phone, have great customer service, and ship quickly.

Share this post


Link to post
Share on other sites
Skibum4106
Posted (edited)

Some one is  getting rich there 


Shop online for OEM Meter parts that fit your 2016 Yamaha FZ07 (FZ07GB), search all our OEM Parts or call at 269-385-1540

I  originally sent an actual  link and this site changed it ..
https://www.cyclepartsnation.com/oemparts/a/yam/55db24e887a8660384734ca9/meter

I had the option to display it as a link however..
  I wonder if  wheelies  will  break the meters  too ?
  I pulled  like 6 screws out of the back but it was like glued shut .. I did not  mess any further..

Edited by Skibum4106
add a link

Share this post


Link to post
Share on other sites
mossrider
1 hour ago, Skibum4106 said:

Some one is  getting rich there 


Shop online for OEM Meter parts that fit your 2016 Yamaha FZ07 (FZ07GB), search all our OEM Parts or call at 269-385-1540

 

Crashing again! Just ordered 2, woot!

Share this post


Link to post
Share on other sites
Skibum4106

         My bike is a:

  FZ-07-GB   I guess GB is for Black ...

 

G is for 2016, B is for black.  (It is the same date code the VIN uses).  My red 2015 is a FZ-07-FR. 

Share this post


Link to post
Share on other sites
cornerslider
1 hour ago, Skibum4106 said:

Oh   My left front  turn signal is not working ..  I  was taking that apart  went ahead  and pulled the meter off.
  It has the part number on it .  The Dealer  I bought the bike from quoted me  $299.00   so  $205.00  is a lot  better than that ..
  I hit the Deer  Insurance  Company estimated  $3,500.00  at  first  the  adjuster did not  believe my forks  were bent  but  in the photos it's  very obvious..  I had a  $500.00   deductible ..  so they wrote me a  check for about  $3,000.00

   The  meter had the part # on it.. My only concern is that maybe the ABS bike  used a  different one..  My bike is a:

  FZ-07-GB   I guess GB is for Black ...

You are correct... The ABS version uses a different dash/display-


""W.O.T. until you see god, then brake"

Share this post


Link to post
Share on other sites
Skibum4106

Thanks  ,,, I think I spotted a compromised  issue with the wire to the  left front Turn signal .. but  I had  Hamburger  frying ..  I have  to  unwrap some Tape .. 
   I will be happy  if it was that easy to find the  problem ..
  Anyway the  Meter had the Part#  on it so I ordered a new one..
  I wonder if Cycle Parts  Nation will  require to any of my attempts to verify correct part  #  Via  message and e-mail

Share this post


Link to post
Share on other sites
mjh937
3 hours ago, Skibum4106 said:

         My bike is a:

  FZ-07-GB   I guess GB is for Black ...

 

G is for 2016, B is for black.  (It is the same date code the VIN uses).  My red 2015 is a FZ-07-FR. 

Oops, sorry @Skibum4106   I accidentally edited your post when I meant to quote it.  I guess the power of an admin is sometimes too much for me ;) .  I will try to be more careful in the future. 

Share this post


Link to post
Share on other sites
Skibum4106
1 hour ago, Skibum4106 said:

Thanks  ,,, I think I spotted a compromised  issue with the wire to the  left front Turn signal .. but  I had  Hamburger  frying ..  I have  to  unwrap some Tape .. 
   I will be happy  if it was that easy to find the  problem ..
  Anyway the  Meter had the Part#  on it so I ordered a new one..
  I wonder if Cycle Parts  Nation will  require to any of my attempts to verify correct part  #  Via  message and e-mail

I can't find what is wrong with the old turn signal  but I  plugged in a new one and it works.. Also the  Meter  booted up just like Normal.. Should I cancel my order for a new meter?  Turned the key off now it won't boot up again ..
  I guess I really do need the new Panel..
  My Insurance is do again too ..  1 year  full Coverage from Dairy-land .. It's the only  thing  I ever had full coverage   on since I paid  off my pickup loan..  Normally just drive old cars with PL & PD Insurance.

Share this post


Link to post
Share on other sites
Skibum4106
9 minutes ago, mjh937 said:

Oops, sorry @Skibum4106   I accidentally edited your post when I meant to quote it.  I guess the power of an admin is sometimes too much for me ;) .  I will try to be more careful in the future. 

That gets confusing..  I did used to know about the letters.. My first  bike was a 1972  GT-80  second  was a  1974 YZ-80 A  third was a  1976 MX-125-C  next  was a  1978 YZ-100-E  so the letters were the year..
  My is all scuffed up  from hitting the Deer ..  I would like to paint it  Yamaha  racing Yellow ..

Share this post


Link to post
Share on other sites
mjh937

Yellow was available in Europe and Australia for 2016.  I am not sure where you could find the plastics in the US but this is what it looked like. 

8B40A427-C77B-42B1-8360-8AD40D94448C.png

  • Like 2

Share this post


Link to post
Share on other sites
Skibum4106

I bought a  2016  Model in  2017,,  It was $400  less for  last years  model and  $400  less with out  ABS  so I paid $800  less and black was the only color the dealer  had  left in stock even though their web site showed the gray and Blue too.
 
  I don't  need any plastic  I plan to paint  what I have .. I know how to paint  colors but don't know how to do the  Yamaha  racing Bar Graphics..  I actually  have a friend  who  paints  award car show and bike show  winning bikes and he says he will help me.
  In the UK there is a Company that makes a Kit for the XSR-900  to make it look like a  1980's   RD / RX-350  I am still the proud owner of one of them..  It has doubled in value  since I bought it.. It is the Yellow  Kenny Roberts autograph version.
https://bikereview.com.au/custom-2018-yamaha-xsr900-rd900lc/

 

 

Share this post


Link to post
Share on other sites
Skibum4106

Annotation 2020-05-09 015358.jpg

Share this post


Link to post
Share on other sites
Skibum4106

Annotation 2020-06-15 121513.jpg

Share this post


Link to post
Share on other sites
D.A.
19 hours ago, Skibum4106 said:

... I pulled  like 6 screws out of the back but it was like glued shut .. I did not  mess any further..

It is possible to open up the meter housing if you want to check the internal connections. I've had mine disassembled. It feels like it's glued shut but it is really just super-tight and tough to pry apart. I realized it was doable after seeing a YouTube video about installing an aftermarket polarizing filter. Here's a link to that video in case you're interested:

 

  • Like 1

Share this post


Link to post
Share on other sites
peteinpa

Been inside mine also, no glue.

  • Like 1

Got new red 2015 FZ-07 on 7/22/16!
Black 2006 Honda ST1300 53K miles.

Share this post


Link to post
Share on other sites
Skibum4106

Thanks  I guess  I will  try a  little harder with a  couple of screw drivers..  I see it has a gasket.. Not  much to loose have a new one ordered..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.