Jump to content
Sign in to follow this  
Jessg562

Keys left on over night , speedometer malfunction help!

Recommended Posts

Jessg562

So I left the keys in the on position over night on my daily rider, 2016 fz 07, battery completely dead. I decided to push start it and after a few tries I got it started,  but as soon as I it drops below about 2k on the rpms, it shuts off. Tried again, rode it around for about 15 minutes before I got caught below 2k rpm again. Then when I did it again just to get home. I also noticed the oil light flashed on and off a few times and the engine light was on the whole ride as well as speedometer was incorrect, saying I was going 40-50 in neutral and idle. I’m not sure if I need a new battery, or if it could possibly be something else besides just the dead battery or

Does it just need a charge ? Any tips or quick responses greatly appreciated! I’m new to motorcycles btw 🤘

Share this post


Link to post
Share on other sites
DewMan

The depleted battery is probably affecting the display. I suggest using the proper battery charger for you battery type and let it charge overnight. If that doesn't return everything to normal, You may have damaged the battery to the point it may need to be replaced.

 

Good luck resolving your issue.

  • Thanks 1

DewMan
 
Just shut up and ride.

Share this post


Link to post
Share on other sites
Jessg562

Appreciate it, I’ll probably just dish out a little coin to get a new one . 

Share this post


Link to post
Share on other sites
DewMan

You should probably still get a proper charger, you're going to need it sooner or later.  They're a lot cheaper than the new battery.

  • Like 2

DewMan
 
Just shut up and ride.

Share this post


Link to post
Share on other sites
motomeek

This happened to me on my other bike... charged the battery and it's like nothing ever happened. 

Check cyclegear - they sometimes have sales on their battery tenders


Instagram: @meekmade | You don't need to flat foot a bike to ride it.

Share this post


Link to post
Share on other sites
robbo10

I wonder if you have actually switched it to off and then switched it back on at all while you were riding or since this happened.  Sometimes they reset themselves this way.  That's after sorting the battery.


Just do it! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


×

Important Information

By using this site, you agree to our Terms of Use.