Jump to content
Sign in to follow this  
wickedtwister

How To: Instal you LED panels from Wickedtwister

Recommended Posts

wickedtwister
This is a quick how to on installing my LED panels.  This How to is written as if the stock turn signals are already removed.  If you wish to retain your stock signals you will need a turn signal splitter from motodynamic or let me know with your order and i will splice the factory style female connector into you LED panels.
 
20150522_170712_zpsioqm4ay0.jpg
 
[span]1: Remove the Front and Rear seat.
 
2: Remove the Body panels between the seats and over the tail light.
 
3: Remove all the Bolts and screws holding the side panels on.  (dont forget about the 6 push pins on the underside of the bike)
 
20150522_163047_zpswcbezywe.jpg
 
4: To remove the side panels grab the rear of the panel near the tail light and gently pull straight out from the tail light. 
 
5: Gently pull the side panel out and away from the bike. 
 
6: Take the Panels to a work bench and removed the 3 round clips holding the panels in place.  Only 2 shown here.
 
20150522_160915_zps33wvywj2.jpg
 
7: Insert your new panels in place of the old ones, and replace the clips.  (Note picture below does not have the clips installed.  also this was taken before i put the wire loom on the power wires on this panel yours will look different. )
 
20150522_154506_zpswvdb8er1.jpg
 
8: Route the wiring harness though the following hole in the frame (Important:  do not route though the hole in front of that or when you put the rear seat on it will pinch the wiring) 
 
60f48661-26a3-41d8-81bf-5eabe7ad136c_zps3wdncaj6.jpg
 
9: Route the wiring to the left hand side of the bike by the connectors.  Any slack can be stored in the area behind the storage compartment.  (Ignore the clutter in my rear compartment.  I have the PCV, Autotune, and Toll road pass modules back there so space is hard to come by. )
 
10: Hook up the harness to the factory wiring harness.  Black to Black, Grey to Grey.
 
20150522_163047_zpswcbezywe.jpg
 
11: Repeat for both sides of course and then reinstall the panels in the reverse order.
 
12: Enjoy your new turn signals.
 
20150506_192512_zpsyyhchlni.jpg
[/span]
  • Like 13

Share this post


Link to post
Share on other sites
motomeek
Thanks for the How To! I got them yesterday and installed them that night. Couldn't wait! Love it! I'll post photos up soon... maybe after my ride at ACH tomorrow!
  • Like 1

Share this post


Link to post
Share on other sites
wickedtwister
Glad you like them. I would love to get to west coast on the bike and ride ACH! Enjoy.
  • Like 1

Share this post


Link to post
Share on other sites
motomeek
So I went to check my lights today and noticed one of the nine LEDs on my right panel were out. 
[attachment id=581" thumbnail="1]
 
Once I got home and opened it up, I noticed one of the bolts that fastens the panel to the frame is above that same LED that was out. I unscrewed it... and found this. 
[attachment id=583" thumbnail="1]
The bolt had gone through some of the glue. Once I took it off, the light is back up and running. So for now, I've just screwed the bolt on loosely until I can purchase a shorter bolt. Then I'll grab a glue gun and close up the hole. 
 
I checked the left side and though it is touching the glue, it didn't penetrate it. But I've loosened it a bit just to make sure. 
 
So @wickedtwister, maybe make the glue on that one a bit shorter in height to accommodate the stock bolt?
 
 
 

Share this post


Link to post
Share on other sites
wickedtwister
Thanks for catching this. I can make the glue thinner but the height of the leads on the back of the led are the same and you could have this issue again. I did see that it was close but I didn't have any issues with my bike. (Similar to your left side I guess) You could stack a few washers under the bolt head to keep it from going down as far. Sorry you ran into this issue. Let me know if you need anything else from me. I will try to source some shorter bolts or something and start including them in the kits.

Share this post


Link to post
Share on other sites
motomeek
No prob! Good idea on the washers. At least the LED still works! That's all that matters!!
 
If you find a recommended bolt length, let me know! I probably won't be able to fix this until next week.

Share this post


Link to post
Share on other sites
sorkyah
Can I still buy them ?
Unfortunately @wickedtwister is no longer a supporting vendor
 
However he has a wonderful how-to on making these beauties here
 
http://fz07.org/thread/2310/custom-rear-led-turn-signals
 
Made a set myself and had the same issue that @motomeek had. ground avout 1/4" off of both bolts
no issues after that

Share this post


Link to post
Share on other sites
cybmx
I'll sell mine soon when I get my hands on the AP 07RS Kit. So if anyone interested in buying these please let me know
  • Like 1

Share this post


Link to post
Share on other sites
Redstang4
I'll sell mine soon when I get my hands on the AP 07RS Kit. So if anyone interested in buying these please let me know
SOLD! To me hopefully
  • Like 1

Share this post


Link to post
Share on other sites
jchin3081
If redstang4 doesn't take it...
  • Like 2

Share this post


Link to post
Share on other sites
cybmx
Cool, I'll keep you guys posted. Now I just have to wait for Andy to get the kit ready... Or maybe I'll just remove them and sell them early.
  • Like 1

Share this post


Link to post
Share on other sites
ssdawood
I'll sell mine soon when I get my hands on the AP 07RS Kit. So if anyone interested in buying these please let me know
 
 
 
What is this a 07rs kit you talk about ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×

Important Information

By using this site, you agree to our Terms of Use.