Jump to content
squrlator

tail light out

Recommended Posts

squrlator
So I was installing a new fender eliminator on my bike, but had to cut the wire for the license plate light, cause the new plate holder uses LED. I was making sure the connection was good and my tail light went out, I think I might have heard a pop noise as well when it happened. Now the tail light/brake light, and the license plate light don't work at all. It doesn't effect anything else on the bike at all, so I'm wondering if maybe it's a fuse. But I really don't know.
 
Does anyone maybe have any ideas on what the problem might be, or how to go about fixing it, I'd really appreciate it. Thanks.

Share this post


Link to post
Share on other sites
YZEtc
Check zee fuses, especially with a pop as the lights went out.

Share this post


Link to post
Share on other sites
squrlator
I'm not sure which one they'd connect to. And all the other lights are working fine

Share this post


Link to post
Share on other sites
squrlator
It's fixed. Thx!

Share this post


Link to post
Share on other sites
YZEtc
What was the reason?

Share this post


Link to post
Share on other sites
squrlator
It totally was a fuse. Just had to change it out... but, now the break light won't come on with the rear brake. Just when I squeeze the front brake. Gonna have to figure that one out

Share this post


Link to post
Share on other sites
rick
You clearly shorted some thing to ground doing the fender eliminator. Find and follow the brake light wire back. It's likely been pinched somewhere or also cut thru.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.